Vulnerability · Published Feb 12, 2025 · Assigned by VulDB

CVE-2025-1215vim main.c memory corruption

Low 2.8

In plain English

A low-severity memory corruption in vim. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.8Low
Exploit odds (30 days)0.5%top 54.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vimno fix listedDEBIAN-CVE-2025-1215
Debian:13vim2:9.1.1113-1DEBIAN-CVE-2025-1215
Debian:14vim2:9.1.1113-1DEBIAN-CVE-2025-1215
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.24USN-7419-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.8USN-7419-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.8UBUNTU-CVE-2025-1215

Affected products (as reported)

VendorProductVersions
n/a vim 9.1.1096

Weakness: CWE-119 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L

References