Vulnerability · Published Oct 20, 2025 · Assigned by CERT-PL
CVE-2025-10678Admin with default credentials in NetBird VPN
Critical 9.3
In plain English
A critical-severity security flaw in NetBird from NetBird VPN. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
NetBird VPN when installed using vendor's provided script failed to remove or change default password of an admin account created by ZITADEL. This issue affects instances installed using vendor's provided script. This issue may affect instances created with Docker if the default password was not changed nor the user was removed. This issue has been fixed in version 0.57.0
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/netbirdio/netbird | 0.57.0 | GHSA-g3j4-58mp-3x25 |
| Go | github.com/netbirdio/netbird | 0.57.0 | GO-2025-4040 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| NetBird VPN | NetBird | 0 – before 0.57.0 |
Weakness: CWE-1392 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://cert.pl/en/posts/2025/10/CVE-2025-10678 third-party-advisory
- https://netbird.io/ product