Vulnerability · Published Sep 15, 2025 · Assigned by VulDB
CVE-2025-10475SpyShelter IOCTL SpyShelter.sys denial of service
Medium 5.5
In plain English
A medium-severity security flaw in SpyShelter. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities).
Official description
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available to the public and could be exploited. Upgrading to version 15.4.0.1028 is able to address this issue. It is advisable to upgrade the affected component.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | SpyShelter | 15.4.0.1015 |
Weakness: CWE-404 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P/RL:O/RC:C
References
- VDB-323906 | SpyShelter IOCTL SpyShelter.sys denial of service vdb-entry
- VDB-323906 | CTI Indicators (IOB, IOC, IOA) signature, permissions-required
- Submit #648484 | SpyShelter <=15.4.0.1012 Local Privilege Escalation third-party-advisory
- https://www.yuque.com/u28538081/sea4q5/aokhgdfpf5ueguk5 exploit
- https://www.spyshelter.com/help/SpyShelter-Changelog#15401028-3sep2025 release-notes