Vulnerability · Published Sep 24, 2025 · Assigned by Perforce
CVE-2025-10360Insufficiently Protected Credentials in Puppet Enterprise 2025.4 and 2025.5
Medium 6.9
In plain English
A medium-severity security flaw in Puppet Enterprise from Perforce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities).
Official description
In Puppet Enterprise versions 2025.4.0 and 2025.5, the encryption key used for encrypting content in the Infra Assistant database was not excluded from the files gathered by Puppet backup. The key is only present on the system if the user has a Puppet Enterprise Advanced license and has enabled the Infra Assistant feature. The key is used for encrypting one particular bit of data in the Infra Assistant database: the API key for their AI provider account. This has been fixed in Puppet Enterprise version 2025.6, and release notes for 2025.6 have remediation steps for users of affected versions who can't update to the latest version.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Perforce | Puppet Enterprise | 2025.4 – through 2025.5 |
Weakness: CWE-522 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N