Vulnerability · Published Sep 10, 2025 · Assigned by AxxonSoft
CVE-2025-10226PostgreSQL Upgrade from v10 to v17.4 in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier to Address Multiple Vulnerabilities
Critical 9.8
In plain English
A critical-severity security flaw in AxxonOne C-Werk from AxxonSoft. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).
Official description
Dependency on Vulnerable Third-Party Component (CWE-1395) in the PostgreSQL backend in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier on Windows and Linux allows a remote attacker to escalate privileges, execute arbitrary code, or cause denial-of-service via exploitation of multiple known CVEs present in PostgreSQL v10.x, which are resolved in PostgreSQL 17.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AxxonSoft | AxxonOne C-Werk | 0 – through 2.0.8 |
Weakness: CWE-1395 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H