Vulnerability · Published Sep 16, 2025 · Assigned by CERT-PL
CVE-2025-10016Local Privilege Escalation in Sparkle Autoupdate Daemon
High 8.8
In plain English
A high-severity incorrect authorization in Sparkle from Sparkle Project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities).
Official description
The Sparkle framework includes a helper tool Autoupdate. Due to lack of authentication of connecting clients a local unprivileged attacker can request installation of crafted malicious PKG file by racing to connect to the daemon when other app spawns it as root. This results in local privilege escalation to root privileges. It is worth noting that it is possible to spawn Autopudate manually via Installer XPC service. However this requires the victim to enter credentials upon system authorization dialog creation that can be modified by the attacker. This issue was fixed in version 2.7.2
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Sparkle Project | Sparkle | 0 – before 2.7.2 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://cert.pl/en/posts/2025/09/CVE-2025-10015 third-party-advisory
- https://github.com/sparkle-project/Sparkle product
- https://github.com/sparkle-project/Sparkle/discussions/2764 vendor-advisory