Vulnerability · Published Feb 19, 2025 · Assigned by Wordfence
CVE-2025-0916YaySMTP 2.4.9 - 2.6.2 - Unauthenticated Stored Cross-Site Scripting
High 7.2
In plain English
A high-severity cross-site scripting in YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service from yaycommerce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities).
Official description
The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: The vulnerability has been initially patched in version 2.4.8 and was reintroduced in version 2.4.9 with the removal of the wp_kses_post() built-in WordPress sanitization function.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| yaycommerce | YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service | 2.4.9 – through 2.6.2 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/209019bd-b214-4389-a972-42e38d501203?source=cve
- https://plugins.trac.wordpress.org/browser/yaysmtp/trunk/includes/Helper/Utils.php
- https://plugins.trac.wordpress.org/browser/yaysmtp/trunk/includes/Functions.php
- https://wordpress.org/plugins/yaysmtp/#developers
- https://plugins.trac.wordpress.org/changeset/3238172