Vulnerability · Published Feb 27, 2025 · Assigned by rapid7
CVE-2025-0914Velociraptor Shell Plugin Prevent_execve Bypass
Low 3.8
In plain English
A low-severity security flaw in Velociraptor from Rapid7. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities).
Official description
An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Rapid7 | Velociraptor | 0 – before 0.73.4 |
Weakness: CWE-281 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N