Vulnerability · Published Sep 23, 2024 · Assigned by GitHub_P
CVE-2024-8770
Medium 5.8
In plain English
A medium-severity cross-site scripting in GitHub Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities).
Official description
A Cross-Site Scripting (XSS) vulnerability was identified in the repository transfer feature of GitHub Enterprise Server, which allows attackers to steal sensitive user information via social engineering. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GitHub | GitHub Enterprise Server | 3.14 – through 3.14.03.13.0 – through 3.13.33.12.0 – through 3.12.83.11.0 – through 3.11.143.10.0 – through 3.10.16 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:L/VA:N/SC:L/SI:N/SA:N
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.1
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.4
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.9
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.15
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.17