Vulnerability · Published Aug 6, 2024 · Assigned by VulDB

CVE-2024-7055FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

Medium 6.3

In plain English

A medium-severity heap buffer overflow in FFmpeg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)1.4%top 26.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23ffmpeg7.1.1-r0ALPINE-CVE-2024-7055
Alpine:v3.24ffmpeg7.1.1-r0ALPINE-CVE-2024-7055
Debian:12ffmpeg7:5.1.6-0+deb12u1DEBIAN-CVE-2024-7055
Debian:12ffmpeg7:5.1.6-0+deb12u1DSA-5748-1
Debian:13ffmpeg7:7.0.2-1DEBIAN-CVE-2024-7055
Debian:14ffmpeg7:7.0.2-1DEBIAN-CVE-2024-7055

Affected products (as reported)

VendorProductVersions
n/a FFmpeg 7.0.07.0.1

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

References