Vulnerability · Published Dec 31, 2024 · Assigned by GitHub_M
CVE-2024-56803Ghostty improperly handles window title sequences which can lead to arbitrary command execution
Medium 5.1
In plain English
A medium-severity code injection in ghostty from ghostty-org. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).
Official description
Ghostty is a cross-platform terminal emulator. Ghostty, as allowed by default in 1.0.0, allows attackers to modify the window title via a certain character escape sequence and then insert it back to the command line in the user's terminal, e.g. when the user views a file containing the malicious sequence, which could allow the attacker to execute arbitrary commands. This attack requires an attacker to send malicious escape sequences followed by convincing the user to physically press the "enter" key. Fixed in Ghostty v1.0.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:26.04:LTS | ghostty | no fix listed | UBUNTU-CVE-2024-56803 |
| Ubuntu:26.10 | ghostty | no fix listed | UBUNTU-CVE-2024-56803 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ghostty-org | ghostty | < 1.0.1 |
Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/ghostty-org/ghostty/security/advisories/GHSA-5hcq-3j4q-4v6p x_refsource_CONFIRM
- https://github.com/ghostty-org/ghostty/pull/3908 x_refsource_MISC