Vulnerability · Published Mar 6, 2025 · Assigned by apache
CVE-2024-56196Apache Traffic Server: ACL is not fully compatible with older versions
Medium 6.3
In plain English
A medium-severity improper access control in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).
Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.8%top 44.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 10.0.4, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2024-56196 |
| Ubuntu:25.10 | trafficserver | no fix listed | UBUNTU-CVE-2024-56196 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 10.0.0 – through 10.0.3 |
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://lists.apache.org/thread/btofzws2yqskk2n7f01r3l1819x01023 vendor-advisory