Actively exploited · Published Dec 18, 2024 · Assigned by GitHub_M

CVE-2024-56145RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms

Critical 9.3 Exploited

In plain English

A critical-severity code injection in cms from craftcms. Attackers are actively exploiting it in the wild (listed by CISA on June 2, 2025). The chance it is exploited in the next 30 days is estimated at 97.5% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)97.5%top 0.1% of all CVEs
Exploited in the wildYesCISA KEV since Jun 2, 2025
Attack tooling3Metasploit, Nuclei, Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Jun 23, 2025.

Official description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms5.5.2GHSA-2p6p-9rc9-62j9
Packagistcraftcms/cms4.13.2GHSA-2p6p-9rc9-62j9
Packagistcraftcms/cms3.9.14GHSA-2p6p-9rc9-62j9

Affected products (as reported)

VendorProductVersions
craftcms cms >= 4.0.0-RC1, < 4.13.2>= 5.0.0-RC1, < 5.5.2>= 3.0.0, < 3.9.14

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References