Vulnerability · Published Dec 12, 2024 · Assigned by GitHub_M
CVE-2024-55662XWiki allows remote code execution through the extension sheet
Critical 10.0
In plain English
A critical-severity incorrect authorization in xwiki-platform from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki Platform is a generic wiki platform. Starting in version 3.3-milestone-1 and prior to versions 15.10.9 and 16.3.0, on instances where `Extension Repository Application` is installed, any user can execute any code requiring `programming` rights on the server. This vulnerability has been fixed in XWiki 15.10.9 and 16.3.0. Since `Extension Repository Application` is not mandatory, it can be safely disabled on instances that do not use it as a workaround. It is also possible to manually apply the patches from commit 8659f17d500522bf33595e402391592a35a162e8 to the page `ExtensionCode.ExtensionSheet` and to the page `ExtensionCode.ExtensionAuthorsDisplayer`.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.platform:xwiki-platform-repository-server-ui | 15.10.9 | GHSA-j2pq-22jj-4pm5 |
| Maven | org.xwiki.platform:xwiki-platform-repository-server-ui | 16.3.0 | GHSA-j2pq-22jj-4pm5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-platform | >= 3.3-milestone-1, < 15.10.9>= 16.0.0-rc-1, < 16.3.0 |
Weakness: CWE-96, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-j2pq-22jj-4pm5 x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/8659f17d500522bf33595e402391592a35a162e8 x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-21890 x_refsource_MISC