Vulnerability · Published Dec 17, 2024 · Assigned by apache

CVE-2024-54677Apache Tomcat: DoS in examples web application

Medium 5.3

In plain English

A medium-severity uncontrolled resource consumption in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.9%top 19.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10tomcat1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:10tomcat-admin-webapps1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:10tomcat-docs-webapp1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:10tomcat-el-5.0-api1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:10tomcat-jsp-3.1-api1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:10tomcat-lib1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:10tomcat-servlet-6.0-api1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:10tomcat-webapps1:10.1.36-1.el10_0ALSA-2025:7497
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
Debian:12tomcat1010.1.34-0+deb12u1DSA-5845-1
Debian:12tomcat1010.1.34-0+deb12u1DEBIAN-CVE-2024-54677
Debian:13tomcat1010.1.34-1DEBIAN-CVE-2024-54677
Debian:14tomcat1010.1.34-1DEBIAN-CVE-2024-54677
Debian:12tomcat99.0.70-2DEBIAN-CVE-2024-54677
Debian:13tomcat99.0.70-2DEBIAN-CVE-2024-54677
Debian:14tomcat99.0.70-2DEBIAN-CVE-2024-54677
Mavenorg.apache.tomcat:tomcat11.0.2GHSA-653p-vg55-5652
Mavenorg.apache.tomcat:tomcat9.0.98GHSA-653p-vg55-5652
Mavenorg.apache.tomcat:tomcat10.1.34GHSA-653p-vg55-5652
Rocky Linux:10tomcat1:10.1.36-1.el10_0RLSA-2025:7497

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.110.1.0-M1 – through 10.1.339.0.0.M1 – through 9.0.978.5.0 – through 8.5.100

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References