Vulnerability · Published Dec 17, 2024 · Assigned by mitre

CVE-2024-54662

Critical 9.1

In plain English

A critical-severity incorrect authorization in the dante package (Alpine). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.5%top 55.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Dante 1.4.0 through 1.4.3 (fixed in 1.4.4) has incorrect access control for some sockd.conf configurations involving socksmethod.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22dante1.4.4-r0ALPINE-CVE-2024-54662
Alpine:v3.23dante1.4.4-r0ALPINE-CVE-2024-54662
Alpine:v3.24dante1.4.4-r0ALPINE-CVE-2024-54662
Debian:12danteno fix listedDEBIAN-CVE-2024-54662
Debian:14dante1.4.4+dfsg-1DEBIAN-CVE-2024-54662
Ubuntu:22.04:LTSdanteno fix listedUBUNTU-CVE-2024-54662
Ubuntu:24.04:LTSdanteno fix listedUBUNTU-CVE-2024-54662
Ubuntu:25.10danteno fix listedUBUNTU-CVE-2024-54662
Ubuntu:26.04:LTSdanteno fix listedUBUNTU-CVE-2024-54662

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References