Vulnerability · Published Mar 20, 2025 · Assigned by apple

CVE-2024-54551

High 7.5

In plain English

A high-severity memory corruption in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 48.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The issue was addressed with improved memory handling. This issue is fixed in Safari 17.6, iOS 17.6 and iPadOS 17.6, macOS Sonoma 14.6, tvOS 17.6, visionOS 1.3, watchOS 10.6. Processing web content may lead to a denial-of-service.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk32.48.1-1.el9_5ALSA-2025:3713
AlmaLinux:9webkit2gtk32.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:8webkit2gtk3-devel2.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk3-devel2.48.1-1.el9_5ALSA-2025:3713
AlmaLinux:9webkit2gtk3-devel2.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:8webkit2gtk3-jsc2.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk3-jsc2.48.1-1.el9_5ALSA-2025:3713
AlmaLinux:9webkit2gtk3-jsc2.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:8webkit2gtk3-jsc-devel2.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk3-jsc-devel2.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:9webkit2gtk3-jsc-devel2.48.1-1.el9_5ALSA-2025:3713
Debian:12webkit2gtk2.48.1-2~deb12u1DSA-5899-1
Debian:12webkit2gtk2.48.1-2~deb12u1DEBIAN-CVE-2024-54551
Debian:13webkit2gtk2.48.1-1DEBIAN-CVE-2024-54551
Debian:14webkit2gtk2.48.1-1DEBIAN-CVE-2024-54551
Debian:12wpewebkitno fix listedDEBIAN-CVE-2024-54551
Debian:13wpewebkit2.48.1-1DEBIAN-CVE-2024-54551
Debian:14wpewebkit2.48.1-1DEBIAN-CVE-2024-54551
Rocky Linux:8webkit2gtk30:2.48.1-1.el8_10RLSA-2025:3974
Rocky Linux:9webkit2gtk30:2.48.1-1.el9_5RLSA-2025:7387
Rocky Linux:9webkit2gtk30:2.48.1-1.el9_5RLSA-2025:3713
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-54551
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-54551
Ubuntu:22.04:LTSwebkit2gtk2.48.1-0ubuntu0.22.04.1UBUNTU-CVE-2024-54551
Ubuntu:22.04:LTSwebkit2gtk2.48.1-0ubuntu0.22.04.1USN-7436-1
Ubuntu:24.04:LTSwebkit2gtk2.48.1-0ubuntu0.24.04.1USN-7436-1
Ubuntu:24.04:LTSwebkit2gtk2.48.1-0ubuntu0.24.04.1UBUNTU-CVE-2024-54551
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2024-54551

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 17.6
Apple iOS and iPadOS 0 – before 17.6
Apple macOS 0 – before 14.6
Apple tvOS 0 – before 17.6
Apple visionOS 0 – before 1.3
Apple watchOS 0 – before 10.6

Weakness: CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References