Vulnerability · Published Jan 29, 2025 · Assigned by Google

CVE-2024-54461Unsanitized Filenames in Flutter package file_selector_android Allow File Overwrites

Low 2.1

In plain English

A low-severity security flaw in file_selector_android from Flutter. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities).

Severity (CVSS 4.0)2.1Low
Exploit odds (30 days)0.2%top 89.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The file names constructed within file_selector are missing sanitization checks leaving them vulnerable to malicious document providers. This may result in cases where a user with a malicious document provider installed can select a document file from that provider while using your app and could potentially override internal files in your app cache. Issue patched in 0.5.1+12. It is recommended to update to the latest version of file_selector_android that contains the changes to address this vulnerability.

Affected products (as reported)

VendorProductVersions
Flutter file_selector_android 0.5.1 – through 0.5.1+11

Weakness: CWE-23 · Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:A/VC:N/VI:L/VA:L/SC:N/SI:H/SA:H

References