Vulnerability · Published Dec 6, 2024 · Assigned by GitHub_M

CVE-2024-54141phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available

High 8.6

In plain English

A high-severity security flaw in phpMyFAQ from thorsten. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.5%top 57.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Prior to 4.0.0, phpMyFAQ exposes the database (ie postgreSQL) server's credential when connection to DB fails. This vulnerability is fixed in 4.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistthorsten/phpmyfaq4.0.0GHSA-vrjr-p3xp-xx2x

Affected products (as reported)

VendorProductVersions
thorsten phpMyFAQ < 4.0.0

Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

References