Vulnerability · Published Dec 2, 2024 · Assigned by GitHub_M

CVE-2024-53986Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0

Low 2.3

In plain English

A low-severity cross-site scripting in rails-html-sanitizer from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.5%top 58.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the "math" and "style" elements are both explicitly allowed. This vulnerability is fixed in 1.6.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsrails-html-sanitizer1.6.1GHSA-638j-pmjw-jq48
Ubuntu:22.04:LTSruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2024-53986
Ubuntu:24.04:LTSruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2024-53986
Ubuntu:25.10ruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2024-53986
Ubuntu:26.04:LTSruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2024-53986
Ubuntu:26.10ruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2024-53986

Affected products (as reported)

VendorProductVersions
rails rails-html-sanitizer >= 1.6.0, < 1.6.1

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References