Vulnerability · Published Nov 29, 2024 · Assigned by GitHub_M

CVE-2024-53864Cross-site Scripting in a field that is used in the Content name pattern in ibexa/admin-ui

Medium 5.3

In plain English

A medium-severity cross-site scripting in admin-ui from ibexa. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.5%top 54.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Ibexa Admin UI Bundle is all the necessary parts to run the Ibexa DXP Back Office interface. The Content name pattern is used to build Content names from one or more fields. An XSS vulnerability has been found in this mechanism. Content edit permission is required to exploit it. After the fix, any existing injected XSS will not run. This issue has been patched in version 4.6.14. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistibexa/admin-ui4.6.14GHSA-8w3p-gf85-qcch

Affected products (as reported)

VendorProductVersions
ibexa admin-ui >= 4.6.0, < 4.6.14

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

References