Vulnerability · Published Nov 27, 2024 · Assigned by GitHub_M
CVE-2024-53860Potential Abuse for Sending Arbitrary Emails in sp-php-email-handler
High 8.6
In plain English
A high-severity injection in SPEmailHandler-PHP from Spencer14420. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
sp-php-email-handler is a PHP package for handling contact form submissions. Messages sent using this script are vulnerable to abuse, as the script allows anybody to specify arbitrary email recipients and include user-provided content in confirmation emails. This could enable malicious actors to use your server to send spam, phishing emails, or other malicious content, potentially damaging your domain's reputation and leading to blacklisting by email providers. Patched in version 1.0.0 by removing user-provided content from confirmation emails. All pre-release versions (alpha and beta) are vulnerable to this issue and should not be used. There are no workarounds for this issue. Users must upgrade to version 1.0.0 to mitigate the vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | spencer14420/sp-php-email-handler | 1.0.0 | GHSA-mj5r-x73q-fjw6 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Spencer14420 | SPEmailHandler-PHP | < 1.0.0 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N