Vulnerability · Published Dec 5, 2024 · Assigned by GitHub_M
CVE-2024-53856rPGP Panics on Malformed Untrusted Input
High 7.5
In plain English
A high-severity security flaw in rpgp from rpgp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 59.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | rust-pgp | 0.14.2-1 | DEBIAN-CVE-2024-53856 |
| Debian:14 | rust-pgp | 0.14.2-1 | DEBIAN-CVE-2024-53856 |
Affected products (as reported)
Weakness: CWE-130, CWE-148, CWE-617 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/rpgp/rpgp/security/advisories/GHSA-9rmp-2568-59rv x_refsource_CONFIRM