Vulnerability · Published Jan 14, 2025 · Assigned by GitHub_M

CVE-2024-53263Git LFS permits exfiltration of credentials via crafted HTTP URLs

High 8.5

In plain English

A high-severity injection in git-lfs from git-lfs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)1.1%top 35.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Git LFS is a Git extension for versioning large files. When Git LFS requests credentials from Git for a remote host, it passes portions of the host's URL to the `git-credential(1)` command without checking for embedded line-ending control characters, and then sends any credentials it receives back from the Git credential helper to the remote host. By inserting URL-encoded control characters such as line feed (LF) or carriage return (CR) characters into the URL, an attacker may be able to retrieve a user's Git credentials. This problem exists in all previous versions and is patched in v3.6.1. All users should upgrade to v3.6.1. There are no workarounds known at this time.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8git-lfs3.4.1-4.el8_10ALSA-2025:0845
AlmaLinux:9git-lfs3.4.1-4.el9_5ALSA-2025:0673
Debian:12git-lfs3.3.0-1+deb12u1DSA-5849-1
Debian:12git-lfs3.3.0-1+deb12u1DEBIAN-CVE-2024-53263
Debian:13git-lfs3.5.0-2DEBIAN-CVE-2024-53263
Debian:14git-lfs3.5.0-2DEBIAN-CVE-2024-53263
Gogithub.com/git-lfs/git-lfsno fix listedGO-2025-3390
Gogithub.com/git-lfs/git-lfsno fix listedGHSA-q6r2-x2cc-vrp7
Gogithub.com/git-lfs/git-lfs/v33.6.1GO-2025-3390
Gogithub.com/git-lfs/git-lfs/v33.6.1GHSA-q6r2-x2cc-vrp7
Rocky Linux:8git-lfs0:3.4.1-4.el8_10RLSA-2025:0845
Rocky Linux:9git-lfs0:3.4.1-4.el9_4RLSA-2025:0673
Ubuntu:25.10git-lfs3.6.1-1ubuntu0.1USN-7977-1

Affected products (as reported)

VendorProductVersions
git-lfs git-lfs >= 0.1.0, < 3.6.1

Weakness: CWE-74 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References