Vulnerability · Published Dec 2, 2024 · Assigned by GitHub_M
CVE-2024-52806SimpleSAMLphp SAML2 has an XXE in parsing SAML messages
High 8.3
In plain English
A high-severity XML external entity in saml2 from simplesamlphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.4%top 62.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC
Official description
SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | simplesamlphp | 1.19.7-1+deb12u1 | DEBIAN-CVE-2024-52806 |
| Debian:12 | simplesamlphp | 1.19.7-1+deb12u1 | DSA-5822-1 |
| Debian:14 | simplesamlphp | 1.19.7-1+deb12u1 | DEBIAN-CVE-2024-52806 |
| Packagist | simplesamlphp/saml2 | 4.6.14 | GHSA-pxm4-r5ph-q2m2 |
| Packagist | simplesamlphp/saml2-legacy | 4.6.14 | GHSA-pxm4-r5ph-q2m2 |
| Ubuntu:24.04:LTS | simplesamlphp | no fix listed | UBUNTU-CVE-2024-52806 |
| Ubuntu:25.10 | simplesamlphp | no fix listed | UBUNTU-CVE-2024-52806 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| simplesamlphp | saml2 | < 4.6.14>= 5.0.0-alpha.1, < 5.0.0-alpha.18 |
Weakness: CWE-611 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L