Vulnerability · Published Dec 2, 2024 · Assigned by GitHub_M
CVE-2024-52596SimpleSAMLphp xml-common XXE vulnerability
High 8.8
In plain English
A high-severity XML external entity in xml-common from simplesamlphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)8.8High
Exploit odds (30 days)1.0%top 37.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
SimpleSAMLphp xml-common is a common classes for handling XML-structures. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 1.19.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | simplesamlphp | 1.19.7-1+deb12u1 | DEBIAN-CVE-2024-52596 |
| Debian:12 | simplesamlphp | 1.19.7-1+deb12u1 | DSA-5822-1 |
| Debian:14 | simplesamlphp | 1.19.7-1+deb12u1 | DEBIAN-CVE-2024-52596 |
| Packagist | simplesamlphp/xml-common | 1.20.0 | GHSA-2x65-fpch-2fcm |
| Ubuntu:24.04:LTS | simplesamlphp | 1.19.7-1+deb12u1ubuntu0.1 | USN-8770-1 |
| Ubuntu:24.04:LTS | simplesamlphp | 1.19.7-1+deb12u1ubuntu0.1 | UBUNTU-CVE-2024-52596 |
| Ubuntu:25.10 | simplesamlphp | no fix listed | UBUNTU-CVE-2024-52596 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| simplesamlphp | xml-common | < 1.20.0 |
Weakness: CWE-611 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:L/SI:L/SA:N