Vulnerability · Published Nov 15, 2024 · Assigned by GitHub_M
CVE-2024-52517Nextcloud Server's global credentials of external storages are sent back to the frontend
Medium 4.6
In plain English
A medium-severity information exposure in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities).
Official description
Nextcloud Server is a self hosted personal cloud system. After storing "Global credentials" on the server, the API returns them and adds them into the frontend again, allowing to read them in plain text when an attacker already has access to an active session of a user. It is recommended that the Nextcloud Server is upgraded to 28.0.11, 29.0.8 or 30.0.1 and Nextcloud Enterprise Server is upgraded to 25.0.13.13, 26.0.13.9, 27.1.11.9, 28.0.11, 29.0.8 or 30.0.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | >= 28.0.0, < 28.0.11>= 29.0.0, < 29.0.8>= 30.0.0, < 30.0.1 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:P/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-x9q3-c7f8-3rcg x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/48359 x_refsource_MISC
- https://github.com/nextcloud/server/commit/c45ed55f959ff54f3ea23dd2ae1a5868a075c9fe x_refsource_MISC
- https://hackerone.com/reports/2554079 x_refsource_MISC