Vulnerability · Published Nov 15, 2024 · Assigned by GitHub_M
CVE-2024-52508Nextcloud Mail auto configurator can be tricked into sending account information to wrong servers
High 8.2
In plain English
A high-severity information exposure in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities).
Official description
Nextcloud Mail is the mail app for Nextcloud, a self-hosted productivity platform. When a user is trying to set up a mail account with an email address like user@example.tld that does not support auto configuration, and an attacker managed to register autoconfig.tld, the used email details would be send to the server of the attacker. It is recommended that the Nextcloud Mail app is upgraded to 1.14.6, 1.15.4, 2.2.11, 3.6.3, 3.7.7 or 4.0.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | >= 1.9.0, < 1.14.6>= 2.1.0, < 2.2.11>= 3.1.0, < 3.6.3>= 1.15.0, < 1.15.4>= 3.7.0, < 3.7.7 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vmhx-hwph-q6mc x_refsource_CONFIRM
- https://github.com/nextcloud/mail/pull/9964 x_refsource_MISC
- https://github.com/nextcloud/mail/commit/a84c70e15d814dab6f0e8eda71bbaaf48152079b x_refsource_MISC
- https://hackerone.com/reports/2508422 x_refsource_MISC