Vulnerability · Published Nov 18, 2024 · Assigned by apache
CVE-2024-52316Apache Tomcat: Authentication bypass when using Jakarta Authentication API
Critical 9.8
In plain English
A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 6.2% (higher than 94% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | tomcat | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:10 | tomcat-admin-webapps | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:10 | tomcat-docs-webapp | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:10 | tomcat-el-5.0-api | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:10 | tomcat-jsp-3.1-api | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:10 | tomcat-lib | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:10 | tomcat-servlet-6.0-api | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:10 | tomcat-webapps | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| Debian:12 | tomcat10 | 10.1.34-0+deb12u1 | DSA-5845-1 |
| Debian:12 | tomcat10 | 10.1.34-0+deb12u1 | DEBIAN-CVE-2024-52316 |
| Debian:13 | tomcat10 | 10.1.31-1 | DEBIAN-CVE-2024-52316 |
| Debian:14 | tomcat10 | 10.1.31-1 | DEBIAN-CVE-2024-52316 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2024-52316 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2024-52316 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2024-52316 |
| Maven | org.apache.tomcat:tomcat-catalina | 9.0.96 | GHSA-xcpr-7mr4-h4xq |
| Maven | org.apache.tomcat:tomcat-catalina | 11.0.1 | GHSA-xcpr-7mr4-h4xq |
| Maven | org.apache.tomcat:tomcat-catalina | 10.1.30 | GHSA-xcpr-7mr4-h4xq |
| Rocky Linux:10 | tomcat | 1:10.1.36-1.el10_0 | RLSA-2025:7497 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.0-M2610.1.0-M1 – through 10.1.309.0.0-M1 – through 9.0.958.5.0 – through 8.5.100 |
Weakness: CWE-391 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H