Vulnerability · Published Nov 12, 2024 · Assigned by GitHub_M

CVE-2024-52301Laravel allows environment manipulation via query string

High 8.7

In plain English

A high-severity argument injection in framework from laravel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 44.8% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)44.8%top 1.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, and 11.31.0. The framework now ignores argv values for environment detection on non-cli SAPIs.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-laravel-frameworkno fix listedDEBIAN-CVE-2024-52301
Debian:13php-laravel-framework10.48.25+dfsg-1DEBIAN-CVE-2024-52301
Debian:14php-laravel-framework10.48.25+dfsg-1DEBIAN-CVE-2024-52301
Packagistlaravel/framework9.52.17GHSA-gv7v-rgg6-548h
Packagistlaravel/framework6.20.45GHSA-gv7v-rgg6-548h
Packagistlaravel/framework11.31.0GHSA-gv7v-rgg6-548h
Packagistlaravel/framework10.48.23GHSA-gv7v-rgg6-548h
Packagistlaravel/framework7.30.7GHSA-gv7v-rgg6-548h
Packagistlaravel/framework8.83.28GHSA-gv7v-rgg6-548h

Affected products (as reported)

VendorProductVersions
laravel framework < 6.20.45>= 7.0.0, < 7.30.7>= 8.0.0, < 8.83.28>= 9.0.0, < 9.52.17>= 10.0.0, < 10.48.23>= 11.0.0, < 11.31.0

Weakness: CWE-88 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References