Vulnerability · Published Nov 13, 2024 · Assigned by GitHub_M

CVE-2024-51996Symphony has an Authentication Bypass via RememberMe

High 7.5

In plain English

A high-severity improper authentication in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 50.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Symphony process is a module for the Symphony PHP framework which executes commands in sub-processes. When consuming a persisted remember-me cookie, Symfony does not check if the username persisted in the database matches the username attached with the cookie, leading to authentication bypass. This vulnerability is fixed in 5.4.47, 6.4.15, and 7.1.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.23+dfsg-1+deb12u4DSA-5813-1
Debian:12symfony5.4.23+dfsg-1+deb12u4DEBIAN-CVE-2024-51996
Debian:13symfony6.4.15+dfsg-1DEBIAN-CVE-2024-51996
Debian:14symfony6.4.15+dfsg-1DEBIAN-CVE-2024-51996
Packagistsymfony/security-http5.4.47GHSA-cg23-qf8f-62rr
Packagistsymfony/security-http6.4.15GHSA-cg23-qf8f-62rr
Packagistsymfony/security-http7.1.8GHSA-cg23-qf8f-62rr
Ubuntu:22.04:LTSsymfonyno fix listedUBUNTU-CVE-2024-51996
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2024-51996
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2024-51996

Affected products (as reported)

VendorProductVersions
symfony symfony >= 5.3.0, < 5.4.47>= 6.0.0-BETA1, < 6.4.15>= 7.0.0-BETA1, < 7.1.8

Weakness: CWE-287, CWE-289 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References