Vulnerability · Published Jun 6, 2024 · Assigned by @huntr_ai
CVE-2024-5131Improper Access Control in lunary-ai/lunary
High 7.5
In plain English
A high-severity authorization bypass via user-controlled key in lunary-ai/lunary from lunary-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities).
Official description
An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| lunary-ai | lunary-ai/lunary | unspecified – before 1.2.25 |
Weakness: CWE-639 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N