Vulnerability · Published Oct 28, 2024 · Assigned by GitHub_M
CVE-2024-49755Duende IdentityServer has insufficient validation of DPoP cnf claim in Local APIs
Low 3.1
In plain English
A low-severity improper authentication in IdentityServer from DuendeSoftware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Duende IdentityServer is an OpenID Connect and OAuth 2.x framework for ASP.NET Core. IdentityServer's local API authentication handler performs insufficient validation of the cnf claim in DPoP access tokens. This allows an attacker to use leaked DPoP access tokens at local api endpoints even without possessing the private key for signing proof tokens. Note that this only impacts custom endpoints within an IdentityServer implementation that have explicitly used the LocalApiAuthenticationHandler for authentication. This vulnerability is patched in IdentityServer 7.0.8. Version 6.3 and below are unaffected, as they do not support DPoP in Local APIs.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| NuGet | duende.identityserver | 7.0.8 | GHSA-v9xq-2mvm-x8xc |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| DuendeSoftware | IdentityServer | >= 7.0.0, < 7.0.8 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N