Vulnerability · Published Oct 16, 2024 · Assigned by GitHub_M

CVE-2024-47889Action Mailer has possible ReDoS vulnerability in block_format

Medium 6.6

In plain English

A medium-severity regular-expression denial of service in rails from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.6Medium
Exploit odds (30 days)0.9%top 39.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Action Mailer is a framework for designing email service layers. Starting in version 3.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the block_format helper in Action Mailer. Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling the `block_format` helper or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1DEBIAN-CVE-2024-47889
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1DSA-5881-1
Debian:13rails2:7.2.2.1+dfsg-1DEBIAN-CVE-2024-47889
Debian:14rails2:7.2.2.1+dfsg-1DEBIAN-CVE-2024-47889
RubyGemsactionmailer6.1.7.9GHSA-h47h-mwp9-c6q6
RubyGemsactionmailer7.0.8.5GHSA-h47h-mwp9-c6q6
RubyGemsactionmailer7.1.4.1GHSA-h47h-mwp9-c6q6
RubyGemsactionmailer7.2.1.1GHSA-h47h-mwp9-c6q6
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2024-47889
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2024-47889
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2024-47889
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2024-47889

Affected products (as reported)

VendorProductVersions
rails rails >= 3.0.0, < 6.1.7.9>= 7.0.0, < 7.0.8.5>= 7.1.0, < 7.1.4.1>= 7.2.0, < 7.2.1.1

Weakness: CWE-1333 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U

References