Vulnerability · Published Oct 21, 2024 · Assigned by GitHub_M
CVE-2024-47825CIDR deny policies may not take effect when a more narrow CIDR allow is present
Medium 4.0
In plain English
A medium-severity incorrect default permissions in cilium from cilium. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.14.0 and prior to versions 1.14.16 and 1.15.10, a policy rule denying a prefix that is broader than `/32` may be ignored if there is a policy rule referencing a more narrow prefix (`CIDRSet` or `toFQDN`) and this narrower policy rule specifies either `enableDefaultDeny: false` or `- toEntities: all`. Note that a rule specifying `toEntities: world` or `toEntities: 0.0.0.0/0` is insufficient, it must be to entity `all`.This issue has been patched in Cilium v1.14.16 and v1.15.10. As this issue only affects policies using `enableDefaultDeny: false` or that set `toEntities` to `all`, some workarounds are available. For users with policies using `enableDefaultDeny: false`, remove this configuration option and explicitly define any allow rules required. For users with egress policies that explicitly specify `toEntities: all`, use `toEntities: world`.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/cilium/cilium | 1.15.10 | GHSA-3wwx-63fv-pfq6 |
| Go | github.com/cilium/cilium | 1.14.16 | GHSA-3wwx-63fv-pfq6 |
| Go | github.com/cilium/cilium | 1.14.16, 1.15.10 | GO-2024-3208 |
Affected products (as reported)
Weakness: CWE-276 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N
References
- https://github.com/cilium/cilium/security/advisories/GHSA-3wwx-63fv-pfq6 x_refsource_CONFIRM