Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47615GHSL-2024-117: GStreamer has an out-of-bounds write in Ogg demuxer

High 8.6

In plain English

A high-severity out-of-bounds write in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.1%top 33.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An OOB-Write has been detected in the function gst_parse_vorbis_setup_packet within vorbis_parse.c. The integer size is read from the input file without proper validation. As a result, size can exceed the fixed size of the pad->vorbis_mode_sizes array (which size is 256). When this happens, the for loop overwrites the entire pad structure with 0s and 1s, affecting adjacent memory as well. This OOB-write can overwrite up to 380 bytes of memory beyond the boundaries of the pad->vorbis_mode_sizes array. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-base1.16.1-5.el8_10ALSA-2024:11345
AlmaLinux:9gstreamer1-plugins-base1.22.1-3.el9_5ALSA-2024:11123
AlmaLinux:8gstreamer1-plugins-base-devel1.16.1-5.el8_10ALSA-2024:11345
AlmaLinux:9gstreamer1-plugins-base-devel1.22.1-3.el9_5ALSA-2024:11123
AlmaLinux:9gstreamer1-plugins-base-tools1.22.1-3.el9_5ALSA-2024:11123
Alpine:v3.20gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47615
Alpine:v3.21gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47615
Alpine:v3.22gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47615
Alpine:v3.23gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47615
Alpine:v3.24gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47615
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DSA-5831-1
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DEBIAN-CVE-2024-47615
Debian:13gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47615
Debian:14gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47615
Rocky Linux:8gstreamer1-plugins-base0:1.16.1-5.el8_10RLSA-2024:11345
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4USN-7175-1
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4UBUNTU-CVE-2024-47615
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2UBUNTU-CVE-2024-47615
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2USN-7175-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-787 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References