Vulnerability · Published Oct 3, 2024 · Assigned by GitHub_M
CVE-2024-47614async-graphql vulnerable to Directive Overload
High 7.5
In plain English
A high-severity resource allocation without limits in async-graphql from async-graphql. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 52.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| async-graphql | async-graphql | < 7.0.10 |
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H