Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47613GHSL-2024-118: GStreamer has a null pointer dereference in gst_gdk_pixbuf_dec_flush

High 8.6

In plain English

A high-severity null pointer dereference in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.9%top 40.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. A null pointer dereference vulnerability has been identified in `gst_gdk_pixbuf_dec_flush` within `gstgdkpixbufdec.c`. This function invokes `memcpy`, using `out_pix` as the destination address. `out_pix` is expected to point to the frame 0 from the frame structure, which is read from the input file. However, in certain situations, it can points to a NULL frame, causing the subsequent call to `memcpy` to attempt writing to the null address (0x00), leading to a null pointer dereference. This vulnerability can result in a Denial of Service (DoS) by triggering a segmentation fault (SEGV). This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-good1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good1.22.1-3.el9_5ALSA-2024:11122
AlmaLinux:8gstreamer1-plugins-good-gtk1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.1-3.el9_5ALSA-2024:11122
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47613
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47613
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47613
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47613
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47613
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47613
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47613
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47613
Rocky Linux:8gstreamer1-plugins-good0:1.16.1-5.el8_10RLSA-2024:11299
Rocky Linux:9gstreamer1-plugins-good0:1.22.1-3.el9_5RLSA-2024:11122
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47613
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47613
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-476 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References