Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47607GHSL-2024-116: Stack-buffer overflow in gst_opus_dec_parse_header

High 8.6

In plain English

A high-severity stack buffer overflow in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.2%top 31.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. stack-buffer overflow has been detected in the gst_opus_dec_parse_header function within `gstopusdec.c'. The pos array is a stack-allocated buffer of size 64. If n_channels exceeds 64, the for loop will write beyond the boundaries of the pos array. The value written will always be GST_AUDIO_CHANNEL_POSITION_NONE. This bug allows to overwrite the EIP address allocated in the stack. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-base1.16.1-5.el8_10ALSA-2024:11345
AlmaLinux:9gstreamer1-plugins-base1.22.1-3.el9_5ALSA-2024:11123
AlmaLinux:8gstreamer1-plugins-base-devel1.16.1-5.el8_10ALSA-2024:11345
AlmaLinux:9gstreamer1-plugins-base-devel1.22.1-3.el9_5ALSA-2024:11123
AlmaLinux:9gstreamer1-plugins-base-tools1.22.1-3.el9_5ALSA-2024:11123
Alpine:v3.20gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47607
Alpine:v3.21gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47607
Alpine:v3.22gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47607
Alpine:v3.23gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47607
Alpine:v3.24gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47607
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DSA-5831-1
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DEBIAN-CVE-2024-47607
Debian:13gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47607
Debian:14gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47607
Rocky Linux:8gstreamer1-plugins-base0:1.16.1-5.el8_10RLSA-2024:11345
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4USN-7175-1
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4UBUNTU-CVE-2024-47607
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2UBUNTU-CVE-2024-47607
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2USN-7175-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-121 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References