Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47603GHSL-2024-251: GStreamer NULL-pointer dereference in Matroska/WebM demuxer

Medium 6.8

In plain English

A medium-severity null pointer dereference in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.8Medium
Exploit odds (30 days)0.9%top 40.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. A null pointer dereference vulnerability has been discovered in the gst_matroska_demux_update_tracks function within matroska-demux.c. The vulnerability occurs when the gst_caps_is_equal function is called with invalid caps values. If this happen, then in the function gst_buffer_get_size the call to GST_BUFFER_MEM_PTR can return a null pointer. Attempting to dereference the size field of this null pointer results in a null pointer dereference. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9gstreamer1-plugins-good1.22.12-4.el9ALSA-2025:7242
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.12-4.el9ALSA-2025:7242
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47603
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47603
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47603
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47603
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47603
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47603
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47603
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47603
Rocky Linux:9gstreamer1-plugins-good0:1.22.12-4.el9RLSA-2025:7242
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47603
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47603
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-476 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References