Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47597GHSL-2024-245: GStreamer has an OOB-read in qtdemux_parse_samples

Medium 5.1

In plain English

A medium-severity out-of-bounds read in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)1.2%top 32.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An OOB-read has been detected in the function qtdemux_parse_samples within qtdemux.c. This issue arises when the function qtdemux_parse_samples reads data beyond the boundaries of the stream->stco buffer. The following code snippet shows the call to qt_atom_parser_get_offset_unchecked, which leads to the OOB-read when parsing the provided GHSL-2024-245_crash1.mp4 file. This issue may lead to read up to 8 bytes out-of-bounds. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9gstreamer1-plugins-good1.22.12-4.el9ALSA-2025:7242
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.12-4.el9ALSA-2025:7242
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47597
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47597
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47597
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47597
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47597
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47597
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47597
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47597
Rocky Linux:9gstreamer1-plugins-good0:1.22.12-4.el9RLSA-2025:7242
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47597
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47597
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-125 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

References