Vulnerability · Published Oct 3, 2024 · Assigned by apache
CVE-2024-47554Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader
Medium 4.3
In plain English
A medium-severity uncontrolled resource consumption in Apache Commons IO from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Uncontrolled Resource Consumption vulnerability in Apache Commons IO. The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input. This issue affects Apache Commons IO: from 2.0 before 2.14.0. Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | commons-io | no fix listed | DEBIAN-CVE-2024-47554 |
| Debian:13 | commons-io | 2.16.0-1 | DEBIAN-CVE-2024-47554 |
| Debian:14 | commons-io | 2.16.0-1 | DEBIAN-CVE-2024-47554 |
| Maven | commons-io:commons-io | 2.14.0 | GHSA-78wr-2p64-hpwj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Commons IO | 2.0 – before 2.14.0 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L