Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47545GHSL-2024-242: GStreamer has an integer underflow in FOURCC_strf parsing leading to OOB-read

Medium 6.9

In plain English

A medium-severity security flaw in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)1.1%top 34.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An integer underflow has been detected in qtdemux_parse_trak function within qtdemux.c. During the strf parsing case, the subtraction size -= 40 can lead to a negative integer overflow if it is less than 40. If this happens, the subsequent call to gst_buffer_fill will invoke memcpy with a large tocopy size, resulting in an OOB-read. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9gstreamer1-plugins-good1.22.12-4.el9ALSA-2025:7242
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.12-4.el9ALSA-2025:7242
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47545
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47545
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47545
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47545
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47545
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47545
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47545
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47545
Rocky Linux:9gstreamer1-plugins-good0:1.22.12-4.el9RLSA-2025:7242
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47545
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47545
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-191 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References