Vulnerability · Published Oct 4, 2024 · Assigned by GitHub_M

CVE-2024-47183Parse Server's custom object ID allows to acquire role privileges

High 8.1

In plain English

A high-severity security flaw in parse-server from parse-community. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 63.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. If the Parse Server option allowCustomObjectId: true is set, an attacker that is allowed to create a new user can set a custom object ID for that new user that exploits the vulnerability and acquires privileges of a specific role. This vulnerability is fixed in 6.5.9 and 7.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server6.5.9GHSA-8xq9-g7ch-35hg
npmparse-server7.3.0GHSA-8xq9-g7ch-35hg

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 6.5.9>= 7.0.0, < 7.3.0

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References