Vulnerability · Published Dec 9, 2024 · Assigned by apache
CVE-2024-46901Apache Subversion: mod_dav_svn denial-of-service via control characters in paths
Low 3.1
In plain English
A low-severity improper input validation in Apache Subversion from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository. All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue. Repositories served via other access methods are not affected.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | subversion | 1.14.5-r0 | ALPINE-CVE-2024-46901 |
| Alpine:v3.21 | subversion | 1.14.5-r0 | ALPINE-CVE-2024-46901 |
| Alpine:v3.22 | subversion | 1.14.5-r0 | ALPINE-CVE-2024-46901 |
| Alpine:v3.23 | subversion | 1.14.5-r0 | ALPINE-CVE-2024-46901 |
| Alpine:v3.24 | subversion | 1.14.5-r0 | ALPINE-CVE-2024-46901 |
| Debian:12 | subversion | 1.14.2-4+deb12u1 | DEBIAN-CVE-2024-46901 |
| Debian:13 | subversion | 1.14.5-1 | DEBIAN-CVE-2024-46901 |
| Debian:14 | subversion | 1.14.5-1 | DEBIAN-CVE-2024-46901 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Subversion | 0 – through 1.14.4 |
Weakness: CWE-20, CWE-116 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L