Vulnerability · Published Nov 22, 2024 · Assigned by apache
CVE-2024-45719Apache Answer: Predictable Authorization Token Using UUIDv1
Low 2.6
In plain English
A low-severity security flaw in Apache Answer from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/apache/incubator-answer | 1.4.1 | GHSA-mr95-vfcf-fx9p |
| Go | github.com/apache/incubator-answer | 1.4.1 | GO-2024-3287 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Answer | 0 – through 1.4.0 |
Weakness: CWE-326 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N