Vulnerability · Published Sep 12, 2024 · Assigned by GitHub_M
CVE-2024-45607whatsapp-api-js fails to validate message's signature
Medium 5.8
In plain English
A medium-severity security flaw in whatsapp-api-js from Secreto31126. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 14.5% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
whatsapp-api-js is a TypeScript server agnostic Whatsapp's Official API framework. It's possible to check the payload validation using the WhatsAppAPI.verifyRequestSignature and expect false when the signature is valid. Incorrect Access Control, anyone using the post or verifyRequestSignature methods to handle messages is impacted. This vulnerability is fixed in 4.0.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | whatsapp-api-js | 4.0.3 | GHSA-mwhf-vhr5-7j23 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Secreto31126 | whatsapp-api-js | >= 4.0.0, < 4.0.3 |
Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N