Vulnerability · Published Jan 27, 2025 · Assigned by GitHub_M
CVE-2024-45598Cacti has a Local File Inclusion (LFI) Vulnerability via Poller Standard Error Log Path
Medium 6.0
In plain English
A medium-severity path traversal in cacti from Cacti. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.0% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Cacti is an open source performance and fault management framework. Prior to 1.2.29, an administrator can change the `Poller Standard Error Log Path` parameter in either Installation Step 5 or in Configuration->Settings->Paths tab to a local file inside the server. Then simply going to Logs tab and selecting the name of the local file will show its content on the web UI. This vulnerability is fixed in 1.2.29.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | cacti | 1.2.29-r0 | ALPINE-CVE-2024-45598 |
| Alpine:v3.22 | cacti | 1.2.29-r0 | ALPINE-CVE-2024-45598 |
| Alpine:v3.23 | cacti | 1.2.29-r0 | ALPINE-CVE-2024-45598 |
| Alpine:v3.24 | cacti | 1.2.29-r0 | ALPINE-CVE-2024-45598 |
| Debian:12 | cacti | 1.2.24+ds1-1+deb12u5 | DSA-5862-1 |
| Debian:12 | cacti | 1.2.24+ds1-1+deb12u5 | DEBIAN-CVE-2024-45598 |
| Debian:13 | cacti | 1.2.28+ds1-4 | DEBIAN-CVE-2024-45598 |
| Debian:14 | cacti | 1.2.28+ds1-4 | DEBIAN-CVE-2024-45598 |
| Ubuntu:24.04:LTS | cacti | no fix listed | UBUNTU-CVE-2024-45598 |
| Ubuntu:25.10 | cacti | no fix listed | UBUNTU-CVE-2024-45598 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L