Vulnerability · Published Nov 13, 2024 · Assigned by GitHub_M

CVE-2024-45594Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds

High 7.7

In plain English

A high-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.3%top 81.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. The meeting embeds feature used in the online or hybrid meetings is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.28.3 and 0.29.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim-meetings0.28.3GHSA-j4h6-gcj7-7v9v

Affected products (as reported)

VendorProductVersions
decidim decidim >= 0.28.0, < 0.28.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

References