Vulnerability · Published Sep 10, 2024 · Assigned by GitHub_M

CVE-2024-45592auditor-bundle vulnerable to Cross-site Scripting because name of entity does not get escaped

High 8.2

In plain English

A high-severity cross-site scripting in auditor-bundle from DamienHarper. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.4%top 61.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

auditor-bundle, formerly known as DoctrineAuditBundle, integrates auditor library into any Symfony 3.4+ application. Prior to version 5.2.6, there is an unescaped entity property enabling Javascript injection. This is possible because `%source_label%` in twig macro is not escaped. Therefore script tags can be inserted and are executed. The vulnerability is fixed in versions 6.0.0 and 5.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistdamienharper/auditor-bundle5.2.6GHSA-78vg-7v27-hj67

Affected products (as reported)

VendorProductVersions
DamienHarper auditor-bundle < 5.2.6

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L

References